AWS: Operational issue - Multiple services (N. Virginia)

Incident Report for Revolear

Resolved

This incident has been resolved for Revolear main Application. Will continue to monitor if any services are still affected, however all appear operational.
Posted Oct 20, 2025 - 19:24 UTC

Update

We are continuing to monitor AWS Activity on this issue.
Posted Oct 20, 2025 - 17:00 UTC

Investigating

Ongoing AWS issue preventing Revolear login / access.
Posted Oct 20, 2025 - 15:30 UTC
This incident affected: Revolear Application.